android - "Gradle Version 2.10 is required." Error

ID : 13415

viewed : 84

Tags : androidandroid-studiopluginsgradleandroid-gradle-pluginandroid





Top 5 Answer for android - "Gradle Version 2.10 is required." Error

vote vote

99

You need to change File > Settings > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home path

On Mac OS, change the path in Android Studio > Preferences > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home

Or set Use default gradle wrapper and edit Project\gradle\wrapper\gradle-wrapper.properties files field distributionUrl like this

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip 
vote vote

88

Open Preference and search for Gradle or Navigate to Builds, Execution, Deployment > Build Tools > Gradle

Then change Project-Level setting to Use default gradle wrapper (recommended)

Or keep local gradle distribution option and set Gradle home to /.../gradle-2.10

Preference screen - Gradle

Make Sure that Gradle version is already setup to 2.10 in Module Settings

On the Project Window, right click on your project then select Open Module Settings (+)

Open Module Settings Project > Gradle version and enter 2.10

Update

Gradle Version: 3.3 Android Plugin version: 2.3.1

vote vote

80

An easier way to accomplish this is to go to: Open Module Settings (your project) > Project > Gradle version and enter 2.10

vote vote

62

Download the latest gradle-3.0-all.zip from

http://gradle.org/gradle-download/

download from Complete Distribution link

open in android studio file ->settings ->gradle

open the path and paste the downloaded zip folder gradle-3.0 in that folder

change your gradle 2.8 to gradle 3.0 in file ->settings ->gradle

Or you can change your gradle wrapper in the project

edit YourProject\gradle\wrapper\gradle-wrapper.properties file and edit the field distributionUrl in to

distributionUrl= https://services.gradle.org/distributions/gradle-3.0-all.zip

vote vote

53

For people who are using Ionic/Cordova framework, we need to change the distributionUrl in GradleBuilder.js file to var distributionUrl = process.env['CORDOVA_ANDROID_GRADLE_DISTRIBUTION_URL'] || 'http\\://services.gradle.org/distributions/gradle-2.10-all.zip';

The GradleBuilder.js locates at project/platforms/android/cordova/lib/builders/GradleBuilder.js

Top 3 video Explaining android - "Gradle Version 2.10 is required." Error







Related QUESTION?